知行社区

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 3806|回复: 0
收起左侧

gedit编辑文本出现乱码的解决方法

[复制链接]
知行 发表于 2012-6-21 15:15 | 显示全部楼层 |阅读模式
些在windows下能够打开的txt文本文件在ubuntu下用gedit打开时,中文显示是乱码,这是因为编码方式不同造成的,windows下有些 txt文件的编码方式gbk,而ubuntu下的gedit默认没有对gdk的支持,所以需要手动配置,在菜单-->System Tool-->Configuration Editor里面/app/gedit-2/preference/encordings里面有个auto-detect,后面的值里面加上 gbk,gb#####之类的就可以了,不行的话,把那几个置顶。


上面这个方法需要将GBK置顶才能用gedit带开gbk格式文档,但是这样会把其他格式的文档处理成乱码,一个比较友好的方法是,在打开文件时,在Charater Coding下拉菜单里选择"Add or Remove...",然后添加GBK或GB18030。

 楼主| 知行 发表于 2012-6-21 15:20 | 显示全部楼层
怎么解决打开记事本中文乱码的问题,ubuntu默认的打开.txt文件用的是gedit,可gedit默认编码是UTF8,打开windows下编辑的gb2312的文档都是乱码。解决方法之一就是把gedit的编码改为GB2312,方法如下:

终端输入gconf-editor调出gconf-edit

PS:输入gconf-editor即可,前面不需要加Sudo

依次点开

apps->gedit-2->preferences->encodings 中的auto-detected

在双击弹出对话框中依次加入GB18030,GBK,GB2312,然后将GB18030,GB2312移到最上

再次打开.txt文件,问题就解决了,很好使,朋友们也试试

gedit3.x版本设置

终端输入dconf-editor

展开org/gnome/gedit/preferences/encodings

auto-detected的value中加入’GB18030′,加在uft8后面;

show-in-menu的value中加入’GB18030′

关于我们|小黑屋|手机版|Archiver|知行技术社区 ( 湘ICP备11020288号-1 )

GMT+8, 2018-10-19 10:05 , Processed in 0.014355 second(s), 10 queries , Gzip On, Redis On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表